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INTRODUCTION

The PC40 to PC file transfer program enhances the utility of the PC40. The portability of the
PC40 allows data to be easily gathered and verified in the field. Then, with the help of the
PC40 to PC file transfer program this data may be brought back into the laboratory for
analysis and formal documentation.

Data gathered in the field must be stored as a CPM file, either on the PC40 Ram disk, or on
the microcassette or floppy disk drives. Individual memories or blocks of 20 memories may be
stored as a file. Data stored in the "RECORD" buffer may also be stored as a file. Refer to
the, "Utilities Functions in Depth", section of the PC40 manual for detailed information on
saving files.

These files may then be transferred from the PC40 to an IBM® PC or compatible clone. Once
transferred, the program allows the files to be viewed in graph and/or tabular form. The graphs
may be appended with notes and other pertinent information for purposes of documentation.
Noise Criteria and Preferred Noise Criteria overlays may be used with the graphs. Filter
weightings of "A" or "C" may be either applied to, or removed from, the octave or 1/3 octave
data.

Any graph that has been created with comments or other data may be stored as a graph file
for future reference and recall. All graphs may be printed using a standard dot-matrix "Epson
Compatible"” printer or an "HP laserjet or Thinkjet " compatible printer.



SYSTEM REQUIREMENTS

PC40 with PC-PC program in ROM (Drive C:)
PC40 serial transfer cable. Ivie part #725.

IBM PC® or compatible with:
CGA color graphics capability with Monochrome or Color monitor
Serial port (may require a female/female gender adapter for #725 cable)
Printer port
Floppy disk drive
Optional Mouse ,

Epson Compatible dot matrix printer or HP compatible laser printer

PC40 to PC program on floppy disk. Version 2.4

MANUAL CONVENTIONS

Throughout this manual we will be using the expression <ecr> (which stands for carriage
return). Whenever you see <cr> it means you should press a certain key on your computer.
Depending upon the labeling of your computer press either the "RETURN", "ENTER" or
"Carriage Return" key when you see <cr>.

Bold type is used to indicate that you are to enter, via the keyboard the bold printed items,
into the computer. You will see text appearing in bold type along with instructions to type the
commands into the computer.

SOFTWARE INSTALLATION
As always it is good practice to make a backup copy of all program disks. So take a minute
now to make a copy of the PC40 to PC program disk. It is not copy protected.

You may run the program directly from the floppy disk or you may install it on your hard drive.
There are two files that are required for operation of the program. First, there is the file
"PC40.EXE", which is the actual program file. The second file is "PC40.PRM" which contains
user supplied preferences or parameters for the program file. These two files must always be
in the same directory.

You will notice that there are other files on the disk. These are sample data files of individual
memories, memory blocks and record buffer files. You may use these files to become
acquainted with the graphing portion of the program. There are batch files that you will use to
select the desired print driver for your printer.

FLOPPY DISK OPERATION
Running the program directly from the floppy disk requires no installation. Insert the floppy

into the default drive and type PC40 <cr>. Remember that <cr> means to press the ENTER
or RETURN key.

You will see a screen that is blank except for a menu bar at the top of the screen. Please refer
to the program operation section of this manual for further details on program operation. To
exit the program and return to the DOS prompt, press and hold the ALT key, while pressing
the "Q" (for quit) key. Then press the <cr> key to return to the DOS prompt.



HARD DISK INSTALLATION/OPERATION

You will need to make a directory for the PC40 program. While in the ROOT directory of your
hard drive, type: MDIR \PC40 <cr>. Next type CD PC40 <cr> to change to the PC40
directory that you have just created. Now place the backup copy of the PC40 to PC program
disk into the A: drive and type the following command: COPY A:*.* <cr> This will copy all of
the files on the floppy into PC40 directory on the hard drive.

You may desire to create a sub-directory in which to store the data files transferred from the
PC40. This will allow you to keep your PC40 directory uncluttered. You could create a sub-
directory for each "job" if desired. Let's say that we wish to create a general sub-directory
called "DATA" in which we will store our files. Type: MDIR \PC40\DATA <cr>. We will
show you how to access this directory from within the file transfer program (see the Change
Default Settings menu under the "File" heading).

HARDWARE SETUP
We will assume that your PC has been functioning properly as a computer with CGA graphics
and with an Epson Compatible dot matrix printer or HP compatible laser printer.

We need to connect the PC40 to the PC. This is accomplished by using the serial connecting
cable for the PC40 (Ivie part #725). The small round end of the cable is connected to the RS-
232 connector on the PC40. The flat rectangular end of the cable goes the RS-232 serial or
COM port on the PC. Please note that you may need to purchase, from a local source, a DB-
25 gender changer (female to female) to allow the cable to match the serial connector on the
computer. '

Some PCs have only one serial connector while some have more then one. Also a serial
connector may already be in use by a mouse. The PC40 to PC program will only recognize
serial communication ports one and two. So we must use port one or port two for the serial
connection between the two computers. The program will automatically look to serial port
number one (COM 1) for the file transfer data. You can use port number two (COM 2) if that
is more convenient, but when you start the program you will need to tell it to look at port
number two. This is accomplished by typing the following when starting the program:
PCEPSON COM2 <cr> (COM2 stands for Serial Communication Port #2). If you have an
available serial port (one or two) connect the #7235 cable to it at this time.

What about the computer that has only one serial communications port and that port is
currently being used by a mouse? Well, you will need to share the port. If your computer has
only one serial port we will assume that this is port number one.

When you wish to make a file transfer, disconnect the mouse and restart the computer by
pressing the following three keys at the same time: Control (Ctrl), Alternate (Alt) and Delete
(Del). Now the computer will not see the mouse connected to the port as it restarts and will
treat it as an available port.



When using serial port one, start the program with the command: PCEPSON <cr> . If
desired, you may quit the program after all the data has been transferred from the PC40 to the
PC, then reconnect the mouse to the serial port and restart the computer as described above.
You can then start the program and have full use of the mouse. The PC40 does not need to
remain connected to the PC once data has been transferred. The PC40 may then be returned
to the field for other measurements.

USING THE PROGRAM WITH OR WITHOUT A MOUSE

The PC40 to PC program will support a mouse but does not require a mouse for operation.
This program uses a pull-down menu system that lends itself to either mouse or keyboard
operation. The keyboard is always active even when a mouse is in use.

Mouse operation

Across the top of the screen are seven menu headers. To gain access to the commands under
the headers you must "pull down" on the header to expose the commands below. To "pull
down" with a mouse, place the mouse cursor on the desired menu header and click the left
mouse button. This will expose all the menu items below that header. To select a particular
item, place the mouse cursor over the desired item and then click the left mouse button.

As other windows are opened and menu items are selected, you will need to use the same
method of point and click. Some windows have a "close window" marker that if pointed to and
clicked upon will close that window without taking any action and return you to the main menu.

The "close window" marker is diamond shaped symbol located in the top left-hand corner of
the window.

When a graph is displayed on the screen and you wish to return to the main menu, press the
left key of the mouse. "

There is a special note about using the mouse in the "Graph Comments Input Screen" (found
under the FILE menu Add Comments selection). The mouse may be used to place the cursor
in any of the fields that you wish to edit. Locate the cursor and then click the left mouse
button. Of special note is that when you are finished editing and you wish to leave the screen,
you must move the mouse outside and below the "Graph Comments Input Screen" and press
the left mouse button.

Keyboard operation

Across the top of the screen are seven menu headers. To gain access to the commands under
the headers you must "pull-down" on the header to expose the commands below. To "pull-
down" a menu with the keyboard, press and hold the "Alt" key while pressing the first letter
of the desired menu item.

For example: To pull down the "File" menu, press and hold the "Alt" key while pressing the
"F" key. By the way, you need not worry about capitalization of the letter. The "f" key could
be used instead of the "F" key.



Now that the "File" menu has been "pulled-down" you can see all of the commands under this
menu header. You will note that the first menu item is highlighted. If you pressed the <cr>
(Enter or Return) key, that item would be selected. To select other items in the menu use the
up and down arrow cursor keys to highlight the menu item of choice. After highlighting your
selection press the <cr> key to select it.

Once a menu has been "pulled down", there is a shortcut that can be used to select a menu
item. You may press the key that corresponds to the first letter of the desired menu item. For
Example: To directly select "Get Plot" press the "G" key. Again, capitalization does not
matter. If there is more than one menu item with the same first letter, then the first item will
be selected with the first press of the key, and the second item will be selected with the
second press of the same key and so on. This alphabetical selection shortcut only works in
the pull-down menus. It does not work in other windows such as "File Select."

The "Esc" key allows you to return to the main menu from other screens. For Example:
When a graph is displayed on the screen, the menu bar at the top of the screen disappears.
This allows maximum display area for the graph. To display the menu above the graph, just
press "Esc.” Remember, "Esc" returns you to the menu. You can also click on left mouse
button to display the menu.

PROGRAM OPERATION
STARTING THE PROGRAM
The PC-PC program can support several different types of printers. Ivie has supplied batch
files that will automatically install the desired printer driver and start the program if you start

the program by using one of the supplied batch files.

Should you start the PC-PC program by typing PC40 you will not be able to print any of the
data. You must start the program with a batch file if you intend to print.

Batch files are supplied for the following printers. Epson compatible dot matrix, HP Thinkjet,
IBM compatible dot matrix, HP laser printers and user defined printers.

If you have an Epson compatible printer connected to your PC then start the PC-PC program
by typing: PCEPSON <cr>.

If you have an IBM compatible printer connected to your PC then start the PC-PC program by
typing: PCIBM <cr>.

If you have an HP compatible laser printer connected to your PC then start the PC-PC program
by typing: PCLASER <cr>.

If you have an HP Thinkjet compatible printer connected to your PC then start the PC-PC
program by typing: PCHPINK <cr>.



If your particular dot matrix printer is not listed above then start the PC-PC program by typing:
PCUSER <cr>. This will start a program that will display a variety of dot matrix printers and
prompt you for input about the mixer.

Remember that the program normally uses the first serial port (COMI1) to communicate with
the PC40. If you are using the second serial port (COM?2) then start the program by typing in
the name of the desired batch file followed by: COM2.

For example: If you have and Epson compatible dot matrix printer connected to your computer
and the PC40 is connected to COM2 then type the following:
PCEPSON COM2 <cr> .

Instructions for operation of the program will be given using examples. The examples will
make use of the sample files included on the program disk. An efficient way to become
familiar with the program is to follow along on your computer with the example.

SELECTING A MEMORY FILE (under the File menu)

The selection of a file to display begins with the "File" pull-down menu selection. After the
"File" menu has been pulled-down you will see two menu items related to selecting a file.
They are "Select Memory File" and "Select Record File."

If you chose "Select Memory File," you will be shown only files that contain data from the
PC40 memories. Files that have the extension of ".MBK" (memory block) contain data from
a block of twenty memories. If a ".MBK" file is selected another menu will be shown that will
allow you to choose which one of the twenty stored memories you wish to display. Files that
have a ".MEM" extension contain only a single memory.

Remember that at the time you saved a file to a disk in the PC40 you were given the choice of
storing memories as a complete block of twenty or as an individual (single) memory.

Lets pull-down the "File" menu and select "Select Memory File" by pressing <cr>. Next the
"File Select" window will appear with two filess DEMO.MBK and DEMO.MEM. Select
DEMO.MBK. We will now see a listing of twelve memories on the screen. The remaining
memories can be viewed by using the down arrow key to scroll them onto the screen. We can
now choose any of the twenty memories by highlighting the desired memory and either clicking
on it with the left mouse button or pressing the <er> key.

You will notice that the "NOTE" you appended to the memory at the time of measurement is
displayed in the file select window. This is to assist you in choosing which memory to display.

Let's select the memory titled "Singing in the lab isn't pretty." The program will now diSplay
the curve on the screen along with other pertinent data. Remember that we can return to the
menu by pressing the "Esc” key or the left button on the mouse.

Selecting a single memory file (".MEM") follows the same process as above with exception
that you will not be shown a second screen from which to choose one of twenty memories.



The above example continues with the next section of this manual. In preparation, return to
the menu by pressing either the "Esc” key or clicking the left button of the mouse.

Now that we have retrieved a file, we can perform some operations on the graph of that file.

EDIT (Main menu item)
The "EDIT" menu allows you to edit the graphic and tabular data.

ADD COMMENTS (Under the EDIT Menu)
The "Add Comments" heading under the "Edit" menu allows you access to the written data
located to the left and bottom of the graph screen.

If you wish to add, delete, or modify the documentation of a graph, select the "Add Comments"
function from the "Edit" menu. Let's try an example. Select the "Singing in the lab isn't
pretty” memory from the "DEMO.MBK" file. After it is up on the screen, return to the menu
(press "Esc or click left mouse button) and select "Add Comments" from the "Edit" menu.

You are now looking at all the data, notes, file name and comments that appear on the screen
with the graph. You can now modify this documentation. The first two lines at the top of the
screen allow you to enter your own company name so that it will appear on the graph. The
two lines for the company name will accept up to fourteen characters. Editing is done with the
cursor and backspace keys. All editing is done in the overwrite mode. Keyboard entries will
overwrite the existing data.

It is important to note that all original data contained in the ".MEM", ".MBK" or ".REC" files
will remain unchanged as all editing is performed only on the screen display.

You will note that the default company name is "IVIE TECHNOLOGIES." This name will
always appear on every graph screen unless you change the default setting. This can be done
under the "File" menu with the "Change Default Parameters" function. Detailed information
on how to do this is in the "Change Default Parameters" section of this manual.

With the "Graph Comments Input Screen" displayed, overwrite "IVIE TECHNOLOGIES"
with your own company name. To view the changes, press the "Esc" key or move the mouse
outside of the "Graph Comments" window and press the left mouse button. You should now
be looking at the graph with your company name.

Now return to the "Graph Comments Input Screen" by returning to the menu and selecting
"Add Comments" under the "Edit" menu. As you edit any field, the computer will only allow
you to enter a limited number of characters per field. Any field that appears on the "Graph
Comments Input Screen" may be edited. There are three lines of notes that may be entered
below the word "Notes." Each of these three lines may have up to seventy-five characters.

Go ahead and experiment by editing some notes on the screen and then viewing the results on
the graph screen. Remember that by pressing the "Esc” key or the left mouse button you will
return to the graph screen.



The above example continues with the next section of the manual. In preparation return to the
menu by pressing either the "Esc” key or clicking the left button of the mouse.

SHOW TABULAR (Under the EDIT Menu)

Another function under the "Edit" menu is "Show Tabular." This function allows the data of
the currently displayed graph to be shown in tabular form. When the function "Print Tabular"
is exercised this data will be sent to the printer as formated on the "Show Tabular" screen.

If you are following along with the above example, select the "Show Tabular" function at this
time so that you may view the tabular data. When ready, return to the main menu by either
pressing the "Esc” key or the left button on the mouse.

PRINT TABULAR (Under the EDIT Menu)

The tabular data that can be viewed by the ."Show Tabular" menu item, may be sent to the
printer using the "Print Tabular" function. Before selecting this function make certain that the
printer is connected to the computer and is "on line" ready to print.

The tabular data that will be printed is from the currently displayed graph. Modifications to the
curve, such as "A" or "C" weighting, will be reflected in the tabular data printout.

If you are following along with the above example, select the "Print Tabular" function at this
time so that you may print the tabular data. Make certain that a printer is connected to the
computer and is ready to print. When finished printing, return to the main menu by either
pressing the "Esc" key or the left button on the mouse.

The above example continues with the next section of this manual. In preparation, return to
the menu by pressing either the "Esc” key or clicking the left button of the mouse.

Edit Curve (Under the EDIT Menu)

The "Edit Curve" menu selection allows you to alter or edit the individual data points on any
displayed curve. If two curves are displayed you will be prompted for which curve you wish to
edit. You then select either curve one or curve two, or if desired you may exit this operation
by selecting the "Cancel” box.

A pop-up window will appear on screen displaying the numerical data for the selected curve.
The data points will be labeled with the frequency. An asterisk beside a frequency label
reminds you that the frequency is an octave band center.

To edit, just type in the new data being sure to type in the decimal point as well. Use the TAB
key to move to the next data field or just click on the new field with the mouse. The SHIFT
TAB will allow you move back through the previous data fields.

There is a "Filter Offset" box that allows a value to be added to, or subtracted from, all filters
at the same time. This is very handy if you are trying to lay one curve over top of another
curve. For example: you could shift the entire curve up by 10 dB by entering the value of 10.0
into the filter offset box. If you desired to shift the curve down by 10 dB you need to enter a
minus sign before entering the value of 10.0.



At any time you can elect to accept the data and exit or to exit the window without making any
changes to the curve.

Please note that any changes made to the displayed curve do not change the original data
stored on the disk. If you wish to keep any changes made in the displayed data you will need
to store the modified curve using the "SAVE PLOT" function found under the "FILE" main
menu.

Create 1/3 Curve (Under the EDIT Menu)
This function allows you to create a custom 1/3 octave curve by allowing you to enter in your
own data points for the curve.

A pop-up window will appear on screen prompting you to enter the numerical data for your
curve. The data points will be labeled with the frequency. An asterisk beside a frequency
label reminds you that the frequency is an octave band center.

Type in the new data being sure to type in the decimal point as well. Use the TAB key to
move to the next data field or just click on the new field with the mouse. The SHIFT TAB will
allow you move back through the previous data fields.

There is a "Filter Offset" box that allows a value to be added to, or subtracted from, all filters
at the same time. This is very handy if you are trying to lay one curve over top of another
curve. For example: you could shift the entire curve up by 10 dB by entering the value of 10.0
into the filter offset box. If you desired to shift the curve down by 10 dB you need to enter a
minus sign before entering the value of 10.0.

At any time you can elect to accept the data and exit or to exit the window without making any
changes to the curve. If you wish to keep any changes made in the displayed data you will
need to store the modified curve using the "SAVE PLOT” function found under the "FILE"
main menu.

Create Oct Curve (Under the EDIT Menu)
This function allows you to create a custom octave curve by allowing you to enter in your own
data points for the curve.

A pop-up window will appear on screen prompting you to enter the numerical data for your
curve. The data points will be labeled with the frequency. An asterisk beside a frequency
label reminds you that the frequency is also an octave band center.

Type in the new data being sure to type in the decimal point as well. Use the TAB key to
move to the next data field or just click on the new field with the mouse. The SHIFT TAB will
allow you move back through the previous data fields.

There is a "Filter Offset" box that allows a value to be added to, or subtracted from, all filters
at the same time. This is very handy if you are trying to lay one curve over top of another
curve. For example: you could shift the entire curve up by 10 dB by entering the value of 10.0
into the filter offset box. If you desired to shift the curve down by 10 dB you need to enter a
minus sign before entering the value of 10.0.
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At any time you can elect to accept the data and exit or to exit the window without making any
changes to the curve. If you wish to keep any changes made in the displayed data you will
need to store the modified curve using the "SAVE PLOT" function found under the "FILE"
main menu.

MODIFY (Main menu item)

There are several modifications that may be made to any displayed curve. A curve may be
modified to reflect "A" ,"C", or "Flat" weighting. Also a second curve may be added to the
graph if desired. Modify also allows the difference between two curves to be displayed.

It should be noted that modifications to the curve do NOT affect the sound pressure level data.
The SPL data is not derived from the the octave or 1/3 octave data but comes from its own
detector at the time of measurement. Weighting of the SPL measurement can not be changed
after the measurement has been taken. ‘

A-Weight (Under the Modify menu)

You can change the "Weighting" of the currently displayed curve to "A" weighting by selecting
this function. If the curve is either "Flat" or "C" weighted it will be changed to "A" weighting.
The graph will then be re-drawn to refect the change in weighting. The change in weighting
will also be reflected in the tabular data of the curve should it be displayed or printed.

C-Weight (Under the Modify menu) :

You can change the "Weighting" of the currently displayed curve to "C" weighting by selecting
this function. If the curve is either "Flat" or "A" weighted it will be changed to "C" weighting.
The graph will then be re-drawn to refect the change in weighting. The change in weighting
will also be reflected in the tabular data of the curve should it be displayed or printed.

UN-Weight (Under the Modify menu)

You can change the "Weighting" of the currently displayed curve to "Flat" weighting by
selecting this function. If the curve is either "A" or "C" weighted it will be changed to "Flat"
weighting. The graph will then be re-drawn to reflect the change in weighting. The change in
weighting will also be reflected in the tabular data of the curve should it be displayed or
printed.

If you are following along with the above example, select one of the modify functions at this
time so that you may view the effect on the curve. When you are ready, return to the main
menu by either pressing the "Esc” key or the left button on the mouse.

Add Second Curve (Under the Modify menu)

A second curve may be plotted along with the first curve for purposes of comparison. When
you use this function you will be brought back to the main menu so that you may access the
"File" menu. When you pull down the "File" menu you will notice that only the "Select
Memory File" and "Select Record File" functions are active. You would then go through the
same selection process as you did for the first curve.
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Because the first curve selected sets the display range of the graph, some thought should be
given in advance as to which curve will be plotted first.

As with the first curve that was plotted, the second curve will be plotted with a data marker at
all data points. However, a different style of data marker will be used to help differentiate
between the two curves.

If you are following along with the above example, select the "Add Second Curve" function at
this time so that you may view the effect upon the curve. When you are finished, return to the
main menu by either pressing the "Esc” key or the left button on the mouse.

Delete Second Curve (Under the Modify menu)

This function will cause the currently displayed graph with two curves to be redrawn without
displaying the second curve. This will delete the second curve and restore the graph to just
one curve.

If you are following along with the above example, select the "Delete Second Curve" function
at this time so that you may view the effect upon the curve. When you are finished, return to
the main menu by either pressing the "Esc” key or the left button on the mouse.

Curve minus Curve (Under the Modify menu) |

This function allows you to compare the difference between two curves that have been
displayed on the screen. You must display two curves on screen before you can use "Curve
minus Curve."

Upon selecting "Curve minus Curve" a pop-up window will appear on the screen. You will
then given the choice of subtracting curve number one from curve number two or vice versa.
Your selection will then be displayed on the graph. You can exit the "Curve minus Curve"
window without performing any operation by selecting the “Cancel" box.

If you wish to once again view both curves after using "Curve minus Curve", go to the
"GRAPH" menu and select "Normal."

GRAPH (main menu item)
The curve may be displayed in one of five different graph formats.

Normal (Under the Graph menu)

Normal is normal. This is the standard amplitude versus frequency graph displayed as a line
graph. This is the default graph display. The graph will automatically set the display range
according to the data being displayed. Also the graph will be set for octave or 1/3 octave
display to match the data in the file.

Each data point is emphasized on the screen. A connecting line is drawn between adjacent
data points. At times there may be a data point that does not have an immediate adjacent
data point due to the constrictions of dynamic range (a filter may be below the invalid data
line). When this happens, a connecting line is not drawn to or from that point. To do so would
infer (visually) that data which does not exist; exists. To return to the menu from the graph
press either the "Esc" key or the left mouse button.
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NC (Under the Graph menu)

Noise Criteria provides a means whereby ambient noise levels in rooms may be quantified. A
reading of the noise in the room is made in octave bands. The NC overlay is then used
determine the NC rating for the room.

When this graph function is selected, an overlay appears on the screen over the normal graph.
Also the NC rating for the curve is calculated and displayed on the screen. The overlay is an
integral part of the plot, and will appear along with the curve when the "Print" or "Save Plot"
functions are used. To return to the menu from the NC graph function press either the "Esc”
key or the left mouse button.

If you are following along with the above example, select the the "NC" function at this time so
that you may view the effect upon the curve. When you are finished, return to the main menu .
by either pressing the "Esc" key or the left button on the mouse.

PNC (Under the Graph menu)
Preferred Noise Criteria provides a means whereby ambient noise levels in rooms may be
quantified. PNC and NC are related to one another in that PNC is a second generation NC
curve. You will notice that different weightings are applied to the noise spectrum by the two
curves. The PNC curves were developed after the NC curves. .

A reading of the noise in the room is made in octave bands. The PNC overlay is then used to
determine the PNC rating for the room.

When this graph function is selected an overlay appears on the screen over the normal graph,
and the PNC rating for the curve is calculated and displayed on the screen. The overlay is an
integral part of the plot, and will appear along with the curve when the "Print" or "Save Plot"
functions are used.

To return to the menu from the PNC graph function press either the "Esc” key or the left
mouse button.

If you are following along with the above example, select the the "PNC" function at this time
so that you may view the effect upon the curve. When you are finished, return to the main
menu by either pressing the "Esc"” key or the left button on the mouse.

NR (Under the Graph menu)
NR is a means whereby ambient noise levels in rooms may be quantified. You will notice
that NR is very similar to NC and PNC. NR is the standard utilized in Great Britain.

A reading of the noise in the room is made in octave bands. The NR overlay is then used to
determine the NR rating for the room. '

When this graph function is selected an overlay appears on the screen over the normal graph
and the NR rating for the curve is calculated and displayed on the screen. The overlay is an
integral part of the plot, and will appear along with the curve when the "Print" or "Save Plot"
functions are used. To return to the menu from the NR graph function press either the "Esc

key or the left mouse button.
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If you are following along with the above example, select the the "NR" function at this time so
that you may view the effect upon the curve. When you are finished, return to the main menu
by either pressing the "Esc" key or the left button on the mouse.

NIC (Under the Graph menu)

NIC requires that two graphs be displayed before you select NIC. These graphs would be the
"send" and "receive" measurements made on opposing sides of a wall or partition. The NIC
calculation will be made and displayed on the screen along with the overlay.

Detailed NIC data may be viewed by selecting the Show Tabular menu found under the Edit
pull-down menu. The the tabular data may be printed by selecting the Print Tabular menu.

Label (Main menu item)

With the PC to PC program you can place labels anywhere on the graphics screen. This
provides great flexibility in documenting your data. Once the label is "typed in" you can
position it with either the mouse or by using the cursor keys. The resolution of the placement
is confined to column and row spacing of text characters.

Add Label (Under the Label menu)

Upon selecting "Add Label" a pop-up window will appear on screen and will prompt you to
input your text for the label. You can enter a single line of up to sixty characters. After
entering the label text, press <cr>.

Now position the the label as desired. Once the label is in position either click the left mouse
button or press <cr> to anchor the label at that location.

You can exit the pop-up text input window, without generating a label, by either clicking on the
diamond symbol in top left hand corner of the window or by pressing the Esc key.

Should you need to reposition the label after it has been set in place, you will need to delete it
and then re-enter the label again.

Delete Label (Under the Label menu)

You can delete any label by selecting selecting Delete Label. A pop-up window will appear on
the screen with a listing of all the labels currently on the screen. Select which label you wish
to delete by clicking on it with the mouse or by using the cursor keys. If you are using a
mouse the label will be deleted at the time you select it. When using the cursor keys to
highlight a label, you will need to press the <cr> key to delete it.

You can exit the pop-up text delete label window, without deleting a label, by either clicking

on the diamond symbol in top left hand corner of the window or by pressing the Esc key.

At this point we would like to conclude our example/demonstration of the PC40 program.
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File (main menu item)

The "File" menu contains those functions that allow us to retrieve and save various files. We
can select files for viewing that we have transferred from the PC40. We can also select files
that we have created and saved as completed graphs.

The "File" menu also contains the utilities for the program. These utility functions include:
Printing, File transfer, and setting program default parameters.

Select Memory File (under the File menu)

The selection of a file to display begins with the "File" pull-down menu selection. After the
"File" menu has.been pulled down, you will see two menu items related to selecting a file.
They are "Select Memory File" and "Select Record File."

If you choose "Select Memory File" you will then be shown only files that contain data from
the PC40 memories. Files that have the extension of ".MBK" contain data from a block
twenty memories. If a ".MBK" file is selected you will then be shown another menu that will
allow you to choose which one of the twenty stored memories you wish to display. Files that
have a ".MEM" extension contain only a single memory.

Remember that at the time you saved a file to a disk in the PC40 you were given the choice of
storing memories as a complete block of twenty, or as an individual (single) memories.

Lets pull down the "File" menu and select "Select Memory File". Next the "File Select"
window will appear with two files: DEMO.MBK and DEMO.MEM. Select DEMO.MBK.
We will now see a listing of fourteen memories on the screen. The other six of the twenty
memories can be viewed by using the down arrow key to scroll them onto the screen. We can
now choose any of the twenty memories by highlighting the desired memory and either clicking
on it with the left mouse button or pressing <cr> key.

Lets select the memory titled "Singing in the Lab isn't pretty”. The program will now display
the curve on the screen along with other pertinent data. Remember that we can return to the
menu by pressing the "Esc” key or the left button on the mouse.

Selecting a single memory file (".MEM") follows the same process as above with exception
that you will not be shown a second screen from which to choose one of twenty memories.

Select Record File (under the File menu)

The selection of a file to display begins with the "File" pull-down menu selection. After the
"File" menu has been pulled down you will see two menu items related to selecting a file.
They are "Select Memory File" and "Select Record File."

The "Select Record File" function provides access to any PC40 Record Buffer files that have
been transferred to the PC. All Record Buffer files are saved with a file extension of ".REC."
When you choose "Select Record File" you will be presented with a new window titled "Select
File," with all record files shown in the window.
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Should you need to exit this window without selecting a file you can do this by either pressing
the "Esc" key or by placing the mouse over the diamond symbol located at the top left-hand
corner of the window and pressing the left mouse button.

To select a file, highlight the desired file by using the mouse or the cursor keys. Once the
desired file is highlighted, select it by pressing the <cr> key or the left mouse button.

Once a file is selected another screen will appear displaying the name of the file selected along
with the number of frames in the file. You will also be prompted for the frame number that you
wish to view. After you enter the frame number press the <er> key. The frame will be
displayed in the normal graph manner. The graph may then be modified or edited as desired.

SAVE PLOT (under the File menu)

The "Save Plot" function allows you to save to the disk, the currently displayed plot or graph.
After you have recalled a memory or record file and modified or edited the graph you can save
all of your changes to a new file. This new file will have a ".GRF" (for graph) extension on its
file name and is a completely different file from the memory or record file. The original memory
or record data file remains totally unchanged.

When you select the "Save Plot" function another screen will appear, prompting you to enter a
name for the new Plot file. The name of the currently displayed memory or record file will be
shown where you are to enter the file name. You need not enter a new file name if you do not
desire to do so. You may elect to use the same file name for the Plot as is used for the data
file. To do this just press <cr> (the Enter or Return key) and the Plot file name will be the
same as the data file name, but with a ".GRF" extension in place of the ".MBK", ".MEM" or
".REC" extension.

A new or different name may be assigned to the file by typing in the desired file name. A file
name may have a maximum of eight characters. The program will not allow you to type the file
extension. The file will automatically assign the ".GRF" extension to the file name.

If you assign a file name that is already in use, the program will prompt you with another
screen informing you that a file already exists using that file name. You will then be prompted
to either overwrite the existing file, rename the file you wish to write, or abort the entire
procedure.

The "Save Plot" function is not available for use until after a graph has been displayed on the
screen. This, of course makes sense in that you cannot save a plot to disk if a plot does not
exist.

If you were to examine the "File" menu when first entering the program, you would notice that
the "Save Plot" and "Print Plot" functions would be displayed in a different screen attribute
than the other headings. This denotes that they are not available at this time. After a plot
has been displayed, the screen attributes of these two functions will change to have the same
screen attributes as the other functions.
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GET PLOT (under the File Menu)

The "Get Plot" function allows you to retrieve and display files that have been saved using the
"Save Plot" function. When you choose "Get Plot" you will be presented with a new window
titled "Select File" which will display a listing of all files with a ".GRF" extension.

Should you need to exit this window without selecting a file you can do this by either pressing
the "Esc" key or by placing the mouse over the diamond located in the top left-hand corner of
the window and pressing the left mouse button.

To select a file, highlight the desired file by using the mouse or the cursor keys. Once
highlighted, select it by pressing the <er> key or the left mouse button.

Print Plot (under the File menu)
The "Print Plot" function sends the currently displayed graph to the printer for printing.

Please note that a printer driver MUST be installed before any printing can occur. The
appropriate driver will be installed automatically when you start the program from one of the
supplied batch files.

For more information on installing the printer driver please refer to the " STARTING THE
PROGRAM" section of this manual. :

TRANSFER DATA FROM PC40 (under the File menu)

Please note: You must save the memories in the PC40 to a CPM computer file before they
can be transferred to the PC. This is done by using the SAVE function in the Utilities section
of the PC40. Typically you would save a block of 20 memories to the "A " drive, which is the
'RAM disk.

There are two programs that must be run at the same time in order to effect a file transfer.
One is on the PC40 and other is on your personal computer. The two computers must be
connected as described in the hardware set up section of this manual.

Start the program on the PC40 first. Turn the PC40 ON and while in the normal analyzer mode
press the red QUIT button. You will now see a listing of programs on the C: or ROM drive.
Use the cursor (arrow) keys to highlight the program "PC-PC BAS." Now press the red
RETURN key. The program will run and provide you with the message on screen "Waiting for
link." The PC40 is now ready to send files to the PC.

Now start the program in the PC by typing name of the desired batch file. The name of the
batch file should describe the type of printer that you have connected to you PC.

The screen on the PC will now display the following:

"Opening COM1 for Link with PC40" (note : it may say COM2 in lieu of COM1)
"Attempting Link with PC40"
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Once the link is established the screen will be updated to display:

"Opening COM1 for Link with PC40"
"Attempting Link with PC40 - Link Established"
"Enter PC40 File Specification for Directory A:*.M??"

You are now being prompted to enter a file specification. The program wants to know from
what source and what types of files you wish to display. The source of the file is determined
by the drive, and the type of file is determined by the extension of the file. Remember that
files may be stored on any of the drives listed below.

Specification Drive type

RAM disk

Floppy disk drive
Floppy disk drive
Floppy disk drive
Floppy disk drive
Microcassette drive

faleivivl e

You will notice that there is a default file specification loaded into the prompt. If you pressed
the <er> key, at the prompt, the program would act upon this specification A:*M??7." Lets
take a moment and examine the default file specification.

The "A:" specifies that we want to read the directory of files on the RAM disk (on the PC40)
which is disk drive "A:". The "* M??" specifies what type of files we want to view in the file
directory. Remember we have three different types of files as listed below.

File Extension Type of File
".MBK" Memory Block of 20 memories
"MEM" Single memory
".REC" Record Buffer file

The "*.M?7?" makes use of what is called wildcard characters in the file specification process.
The "*" means give me any file name with the following extension. The extension ".M??"
means give me all file names with extensions that have the letter "M" as their first letter.
The "?7" hold the place for the other two letters in the extension and are also wildcards. So
the file specification "A:*.M?? will request the directory of ALL files (regardless of their file
name) on the "A:" drive that have a ".MBK" or ".MEM" extension.

You may use the default file specification by pressing the <cr> key or you may enter your own
specification by typing over the default spec. A spec of "*.*" will allow you to view all
available files. A spec of "*.REC" will show you only the record buffer files.

This shows you a directory of file names that meet your specification and does not actually
transfer any files. These files will be displayed in the "File Directory” window on the PC.
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Once in the PC40 File Directory window you can select which file you would like to transfer to
the PC. You select the file by highlighting it with either the mouse or cursor keys and
pressing the <cr> key or left mouse button. You will notice a file called "ALL Files" in the
window. This allows you to transfer all the files in the directory with one command.

Once an individual file or "ALL Files" has been requested, the screens of the PC40 and PC
will display the progress of the transfer process. After a file is transferred, the PC will again
show you the PC40 file directory window so that you may select another file to transfer. If you
are finished transferring files, then press either the "Esc" key or click the mouse on the close
window symbol to return to the main menu.

To return the PC40 to the analyzer mode, press the red QUIT button to quit the transfer
program. You should now see a screen with a listing of programs in the various drives. The
program "C:PC40Vxx COM"(xx varies with release #) should be highlighted. This is the
program that runs the computer as an analyzer. With the "C:PC40Vxx COM" program
highlighted, press the <cr> (Return) key start the analyzer.

What happens when you press the red QUIT button and you do not return to the screen that
was described above. Instead you see something like "DT Error in 30" followed by the prompt
"Ok." If at anytime you see a screen that you are not familiar with, and it has the word "Ok",
you are in the BASIC programming section of the computer. The PC40 portion of the file
transfer program is written in BASIC.

The way to exit BASIC is to type in the word System and press <cr>. This will return you to
the screen displaying "C:PC40Vxx COM". Now press the <cr> key once more to start the
analyzer.

The PC40 may be disconnected from the PC at this time. The PC40 is no longer needed by the
PC.

Change Default Parameters (under the File menu)

There are two default parameters that can be set by the user. These parameters are stored in
a file called "PC40.PRM" This file must always be in the same directory as the "PC40.EXE"
program.

When this function is selected you will see the following information displayed in the window:

Current Path Spec to IBM Data Directory=
Enter New Path for IBM Data Directory- (a flashing cursor will appear here)

Notice that the space after "Current Path Spec to IBM Data Directory=" is blank. This
indicates that it is currently set to the same directory as the "PC40.EXE" program. Any time
the program looks for a file or goes to store a file it will look at the directory that contains the
"PC40.EXE" program. We will call this the default directory.

The sample files that came with the software are stored in the default directory. If you change
the default directory and you wish to access these files you should copy them over to the new
directory.
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Now, what about the flashing cursor at the end of the prompt:
Enter New Path for IBM Data Directory- (a flashing cursor will appear here)

If you press the <cr> key without entering a new path, then nothing will be changed. The
default directory will remain unchanged. Lets say that you wish to store and retrieve your
data files from a sub-directory, under the "PC40" directory. You wish to do this so as not to
clutter your PC40 directory. We will assume that you have already created a sub-directory
called "Data" using the DOS command MDIR\PC40\DATA <cr>. Then, at the prompt, type
the following:

Enter New Path for IBM Data Directory-\PC40\DATA <cr>

Now every time the program does anything that requires a file, it will only act upon files found
in the \PC40\DATA directory. It will not know about any other files located in any other
directories. You could create a separate sub-directory for each job that you perform.

Keep in mind that in order to use a different sub-directory two things must take place. First
you must create a sub-directory in DOS for the data. And second, you must tell the PC-PC
program about the new directory using the "Change Default Parameters” function.

Once you have taken care of the Directory prompt, you will see the next prompt:

Current Company Name 1=Ivie
Enter New Company Name 1 - Ivie (with a flashing cursor over the "I")

Unless you want Ivie's name to appear on all of your graphs, type in the name of your
company. The "Name 1" line will accept up to fourteen characters. There is also a "Name 2"
line that will also accept fourteen characters, so don't worry if your company name will not fit
on "Name 1" line.

After entering the name of your company, press the <cr> key. You will now see the prompt:

Current Company Name 2= Technologies

Enter New Company Name 2 - Technologies
(with a flashing cursor over the "T")

If a second line is needed for your company name, enter it at this time. If you wish to have this
line appear blank on the screen then enter a series of spaces to overwrite the existing name.
Now press the <cr> key.

At this point the program will save the default parameters that you have entered in the
"PC40.PRM" file. The program will then refer to this file any time file or company name
information is required.
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